The Web's Only Official All-Scorpion Forum!


 
HomePortalCalendarFAQSearchRegisterMemberlistUsergroupsLog in
ChatBox

Share | 
 

 Lost an emp yesterday!

View previous topic View next topic Go down 
AuthorMessage
tfleming
Tityus
avatar

Number of posts : 589
Age : 64
Location : Cedar Creek, Tx
Registration date : 2011-07-18

PostSubject: Lost an emp yesterday!   4/23/2012, 5:41 pm

I had 2 gravid emps and 1 gave birth back in Feb. She and the babies are doing great. Since my wife bought 1 the of the female for me I had no idea how far along she was, but judging by the size I thought she would deliver soon. Over the pass few days she was very slow and listless. Yesterday after Church I reached into the tank and picked her up and she was dead. I decided to do a makeshift necropsy and found she had several very large embryos inside. Is it possible that they were to large for her to deliver? My other emp had babies and they were half the size of these. Hated to see her go. I got the tank to stay about 80 to 85 degrees and around 80% humidity. I thought this was perfect. Sad
Back to top Go down
View user profile
Scorpion19981000
Administrator
avatar

Number of posts : 1895
Age : 19
Location : Cortland, New York
Registration date : 2011-07-03

PostSubject: Re: Lost an emp yesterday!   4/23/2012, 7:51 pm

That sucks. RIP I have no idea why she died, the temp and humidity sounds fine.

_________________
"Life is a gamble. You can get hurt, but people die in plane crashes, lose their arms and legs in car accidents; people die every day. Same with fighters: some die, some get hurt, some go on. You just donít let yourself believe it will happen to you."
-Muhammad Ali

My Youtube Channel.
My inverts:
 
Back to top Go down
View user profile http://www.scorpionforum.darkbb.com
**GS**
Leiurus
avatar

Number of posts : 2629
Age : 35
Location : facebook.com/ScorpionArchives
Registration date : 2010-09-06

PostSubject: Re: Lost an emp yesterday!   4/23/2012, 10:34 pm

Sorry to hear that bro.

Don't push yourself too hard on this, you can never be certain of her age when you get them as adults.

I didn't think it was due to the large embryos but possibly due to old age, her body might not be capable of sustaining a brood.

How are the other babies doing?
Back to top Go down
View user profile
DolbyR
Leiurus
avatar

Number of posts : 2097
Age : 35
Location : facebook.com/ScorpionArchives
Registration date : 2011-01-03

PostSubject: Re: Lost an emp yesterday!   4/24/2012, 2:16 am

GS wrote:
Sorry to hear that bro.

Don't push yourself too hard on this, you can never be certain of her age when you get them as adults.

I didn't think it was due to the large embryos but possibly due to old age, her body might not be capable of sustaining a brood.

+1

I lost one M. martensii this way, 2-3 months into gestation and she just dropped dead. Within 6 months time, the remaining 3 specimen deceased too.
Some of them with severe mycosis, but IMO old age was the cause.
Back to top Go down
View user profile http://allscorpionarchives.forumotion.com
tfleming
Tityus
avatar

Number of posts : 589
Age : 64
Location : Cedar Creek, Tx
Registration date : 2011-07-18

PostSubject: Re: Lost an emp yesterday!   4/24/2012, 1:52 pm

The other babies and mom are doing great! Thanks for the input!
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Lost an emp yesterday!   

Back to top Go down
 
Lost an emp yesterday!
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» LOST Husky
» Lost in SFG...
» Made pesto yesterday
» Ever lost sight of your scorpion for months at a time?
» No more lost Text.

Permissions in this forum:You cannot reply to topics in this forum
The Web's Only Official All-Scorpion Forum! :: The Scorpion's Lair :: The Burrow in Ghana: Emperor Zone-
Jump to: